summaryrefslogtreecommitdiff
path: root/gpr/source/lib/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gpr/source/lib/common/CMakeLists.txt')
-rw-r--r--gpr/source/lib/common/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/gpr/source/lib/common/CMakeLists.txt b/gpr/source/lib/common/CMakeLists.txt
new file mode 100644
index 0000000..103b6c2
--- /dev/null
+++ b/gpr/source/lib/common/CMakeLists.txt
@@ -0,0 +1,18 @@
+# library
+set( LIB_NAME common )
+
+# get source files
+file( GLOB SRC_FILES "private/*.cpp" "private/*.c" )
+
+# get include files
+file( GLOB INC_FILES "private/*.h" "public/*.h" )
+
+include_directories( "./public" )
+
+# library
+add_library( ${LIB_NAME} STATIC ${SRC_FILES} ${INC_FILES} )
+
+target_link_libraries( ${LIB_NAME} )
+
+# set the folder where to place the projects
+set_target_properties( ${LIB_NAME} PROPERTIES FOLDER lib )