summaryrefslogtreecommitdiff
path: root/gpr/source/lib/md5_lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gpr/source/lib/md5_lib/CMakeLists.txt')
-rw-r--r--gpr/source/lib/md5_lib/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/gpr/source/lib/md5_lib/CMakeLists.txt b/gpr/source/lib/md5_lib/CMakeLists.txt
new file mode 100644
index 0000000..5782609
--- /dev/null
+++ b/gpr/source/lib/md5_lib/CMakeLists.txt
@@ -0,0 +1,23 @@
+# library
+set( LIB_NAME md5_lib )
+
+# get source files
+file( GLOB BASE_SRC_FILES "*.c" )
+
+# get include files
+file( GLOB BASE_INC_FILES "*.h" )
+
+# get all source files
+set( SRC_FILES ${BASE_SRC_FILES} )
+
+# get all include files
+set( INC_FILES ${BASE_INC_FILES} )
+
+
+# library
+add_library( ${LIB_NAME} STATIC ${SRC_FILES} ${INC_FILES} )
+
+target_link_libraries( ${LIB_NAME} )
+
+# set the folder where to place the projects
+set_target_properties( ${LIB_NAME} PROPERTIES FOLDER lib )