summaryrefslogtreecommitdiff
path: root/gpr/source/lib/vc5_decoder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gpr/source/lib/vc5_decoder/CMakeLists.txt')
-rw-r--r--gpr/source/lib/vc5_decoder/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/gpr/source/lib/vc5_decoder/CMakeLists.txt b/gpr/source/lib/vc5_decoder/CMakeLists.txt
new file mode 100644
index 0000000..d78522d
--- /dev/null
+++ b/gpr/source/lib/vc5_decoder/CMakeLists.txt
@@ -0,0 +1,22 @@
+# library
+set( LIB_NAME vc5_decoder )
+
+# get source files
+file( GLOB SRC_FILES "*.c" )
+
+# get include files
+file( GLOB INC_FILES "*.h" )
+
+# add include files from other folders
+include_directories( "../vc5_common" )
+include_directories( "../common/private" )
+include_directories( "../common/public" )
+
+
+# library
+add_library( ${LIB_NAME} STATIC ${SRC_FILES} ${INC_FILES} )
+
+target_link_libraries( ${LIB_NAME} )
+
+# set the folder where to place the projects
+set_target_properties( ${LIB_NAME} PROPERTIES FOLDER lib )