summaryrefslogtreecommitdiff
path: root/gpr/source/app/common/argument_parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gpr/source/app/common/argument_parser/CMakeLists.txt')
-rw-r--r--gpr/source/app/common/argument_parser/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/gpr/source/app/common/argument_parser/CMakeLists.txt b/gpr/source/app/common/argument_parser/CMakeLists.txt
new file mode 100644
index 0000000..e965221
--- /dev/null
+++ b/gpr/source/app/common/argument_parser/CMakeLists.txt
@@ -0,0 +1,16 @@
+# library
+set( LIB_NAME argument_parser )
+
+# get source files
+file( GLOB SRC_FILES "*.c" "*.cpp" )
+
+# get include files
+file( GLOB INC_FILES "*.h" )
+
+# library
+add_library( ${LIB_NAME} STATIC ${SRC_FILES} ${INC_FILES} )
+
+target_link_libraries( ${LIB_NAME} )
+
+# set the folder where to place the projects
+set_target_properties( ${LIB_NAME} PROPERTIES FOLDER lib )